Support Center

Software

Last Updated: Jul 02, 2014 12:09PM EDT
These minimal system requirements allow optimal performance in our poker application:
  • Google Chrome v 34.0
  • Mozilla Firefox v 28.0
  • Internet Explorer 11 v 11.0
  • Safari OS X 10.9.1 (or later version)
  • Flash Player v 13.0
For tablet/mobile use be sure to install the most current version of Flash Player. To ensure this is done, proceed to http://get.adobe.com/flashplayer/?promoid=JZEFT the click the 'Here' tab for the plug in. You will be prompted to click the 'Install Now' yellow box then run the dialogue box and follow the on-screen prompts.

Contact Us

  • Post a Public Question
  • Email Us
  • Call Us @ 844.367.7252
ae49f201922e60685fc40680a5529e82@palainteractive.desk-mail.com
http://assets0.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete